bookmark_borderGravity Forms System Requirements

Many users ask for the web server system requirements for Gravity Forms before purchase. We recommend the same system requirements as WordPress itself. The current system requirements for WordPress are as follows:

  • PHP version 5.6+
  • MySQL version 5.5+
  • Latest version of WordPress
Please Note: If you are in a legacy environment where you are running older versions of PHP or MySQL, Gravity Forms may also work with PHP v5.3+ and MySQL v5.0+, but these versions have reached official End of Life and may expose your site to security vulnerabilities. We highly recommend contacting your host to upgrade to at least PHP v7.0+, MySQL v5.6+ and the latest version of WordPress.

If your PHP version is not listed on the supported versions page you really should update to a more recent version. Please check with your web host to update PHP to a more recent version.

See our article about the importance of updates.

Checking For Compatibility Within Gravity Forms

A lot of environment information can be found within your System Status page, found under the Forms menu item in the admin area. See this article for more information.

Gravity Forms System Status Page